Quantcast

[Nanocubes-discuss] Fwd: Following initial setup, ncserve not found

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

[Nanocubes-discuss] Fwd: Following initial setup, ncserve not found

Lodgen, Brad
Sent these earlier, but apparently wasn't a member of the group. Got that fixed now. Anyone have any thoughts?

Thanks btw, Carlos!




-------- Original Message --------
Subject: RE: Following initial setup, ncserve not found
From: "Lodgen, Brad" <[hidden email]>
To: "'[hidden email]'" <[hidden email]>
CC:

I ran make again and ncserve is now available, but now when running, I get this:

[root@X scripts]# python csv2Nanocube.py --catcol='Primary Type' crime50k.csv | NANOCUBE_BIN=../src  ../src/ncserve --rf=100000 --threads=100
VERSION: 2014.03.25_13:26
Traceback (most recent call last):
  File "csv2Nanocube.py", line 1, in <module>
    import sys,dateutil,datetime,argparse,re,subprocess,os,json,socket
ImportError: No module named dateutil
Dimensions:
Variables:
Could not find program: ../src/nc

Did a locate and this is the only nc file:

[root@min-nano-01 scripts]# locate "/src/nc"
/root/nanocube-2.1/src/nc.cc

I ran the compile process over again and no difference. 

Why would it not be compiling some of these files? I'm not the most experienced with compiling, so maybe I'm missing something. I appreciate any help. Thanks!



From: X
Sent: Tuesday, June 17, 2014 3:54 PM
To: '[hidden email]'
Subject: Following initial setup, ncserve not found

Hey guys, getting ncserve not found when trying to run the final setup test command. Did the compile go wrong, possibly?

 

I’m running Fedora 20,

 

 

Details:

 

Successfully installed numpy pandas python-dateutil pytz six

 

[root@X ~]# cd nanocube-2.1/

 

[root@X nanocube-2.1]# cd web/

 

[root@X web]# python -m SimpleHTTPServer &

[1] 16123

[root@X web]# Serving HTTP on 0.0.0.0 port 8000 ...

 

[root@X web]# cd ../scripts/

 

[root@X scripts]# python csv2Nanocube.py --catcol='Primary Type' crime50k.csv | NANOCUBE_BIN=../src ../src/ncserve --rf=100000 --thread=100

-bash: ../src/ncserve: No such file or directory

Traceback (most recent call last):

  File "csv2Nanocube.py", line 1, in <module>

    import sys,dateutil,datetime,argparse,re,subprocess,os,json,socket

ImportError: No module named dateutil

[root@X scripts]# updatedb

[root@X scripts]# locate ncserve

/root/nanocube-2.1/src/ncserve.cc

/root/nanocube-2.1/src/.deps/ncserve.Po

 

 

 

 

Installed versions:

 

[root@X nanocube-2.1]# yum list installed | grep gcc

gcc.x86_64                             4.8.2-7.fc20                    @updates

gcc-c++.x86_64                         4.8.2-7.fc20                    @updates

libgcc.x86_64                          4.8.2-7.fc20                    @updates

 

[root@X nanocube-2.1]# yum list installed | grep autoconf

autoconf.noarch                        2.69-14.fc20                    @updates

 

[root@X nanocube-2.1]# yum list installed | grep boost

boost.x86_64                           1.54.0-9.fc20                   @updates

boost-atomic.x86_64                    1.54.0-9.fc20                   @updates

boost-chrono.x86_64                    1.54.0-9.fc20                   @updates

boost-context.x86_64                   1.54.0-9.fc20                   @updates

boost-date-time.x86_64                 1.54.0-9.fc20                   @updates

boost-devel.x86_64                     1.54.0-9.fc20                   @updates

boost-filesystem.x86_64                1.54.0-9.fc20                   @updates

boost-graph.x86_64                     1.54.0-9.fc20                   @updates

boost-iostreams.x86_64                 1.54.0-9.fc20                   @updates

boost-locale.x86_64                    1.54.0-9.fc20                   @updates

boost-log.x86_64                       1.54.0-9.fc20                   @updates

boost-math.x86_64                      1.54.0-9.fc20                   @updates

boost-program-options.x86_64           1.54.0-9.fc20                   @updates

boost-python.x86_64                    1.54.0-9.fc20                   @updates

boost-random.x86_64                    1.54.0-9.fc20                   @updates

boost-regex.x86_64                     1.54.0-9.fc20                   @updates

boost-serialization.x86_64             1.54.0-9.fc20                   @updates

boost-signals.x86_64                   1.54.0-9.fc20                   @updates

boost-system.x86_64                    1.54.0-9.fc20                   @updates

boost-test.x86_64                      1.54.0-9.fc20                   @updates

boost-thread.x86_64                    1.54.0-9.fc20                   @updates

boost-timer.x86_64                     1.54.0-9.fc20                   @updates

boost-wave.x86_64                      1.54.0-9.fc20                   @updates

ibus-typing-booster.noarch             1.2.5-1.fc20                    @anaconda

 

[root@X nanocube-2.1]# yum list installed | grep python

abrt-addon-python.x86_64               2.1.9-1.fc20                    @anaconda

abrt-python.x86_64                     2.1.9-1.fc20                    @anaconda

audit-libs-python.x86_64               2.3.2-1.fc20                    @anaconda

boost-python.x86_64                    1.54.0-9.fc20                   @updates

dbus-python.x86_64                     1.2.0-1.fc20                    @anaconda

gnome-python2.x86_64                   2.28.1-13.fc20                  @anaconda

gnome-python2-canvas.x86_64            2.28.1-13.fc20                  @anaconda

langtable-python.noarch                0.0.23-1.fc20                   @anaconda

liblouis-python3.noarch                2.5.3-2.fc20                    @anaconda

libreport-python.x86_64                2.1.9-1.fc20                    @anaconda

libselinux-python.x86_64               2.1.13-19.fc20                  @anaconda

libsemanage-python.x86_64              2.1.10-14.fc20                  @anaconda

libuser-python.x86_64                  0.60-3.fc20                     @anaconda

libxml2-python.x86_64                  2.9.1-2.fc20                    @anaconda

newt-python.x86_64                     0.52.16-1.fc20                  @anaconda

notify-python.x86_64                   0.1.1-25.fc20                   @anaconda

policycoreutils-python.x86_64          2.2.2-3.fc20                    @anaconda

python.x86_64                          2.7.5-11.fc20                   @updates

python-GnuPGInterface.noarch           0.3.2-12.fc20                   @anaconda

python-IPy.noarch                      0.75-6.fc20                     @anaconda

python-boto.noarch                     2.13.3-1.fc20                   @anaconda

python-caribou.noarch                  0.4.13-1.fc20                   @anaconda

python-chardet.noarch                  2.0.1-7.fc20                    @anaconda

python-cloudfiles.noarch               1.7.10-4.fc20                   @anaconda

python-cssselect.noarch                0.8-1.fc20                      @anaconda

python-cups.x86_64                     1.9.63-4.fc20                   @anaconda

python-decorator.noarch                3.4.0-3.fc20                    @anaconda

python-decoratortools.noarch           1.8-7.fc20                      @anaconda

python-deltarpm.x86_64                 3.6-3.fc20                      @anaconda

python-devel.x86_64                    2.7.5-11.fc20                   @updates

python-iniparse.noarch                 0.4-9.fc20                      @anaconda

python-inotify.noarch                  0.9.4-4.fc20                    @anaconda

python-javapackages.noarch             3.4.1-1.fc20                    @anaconda

python-kitchen.noarch                  1.1.1-5.fc20                    @anaconda

python-krbV.x86_64                     1.0.90-7.fc20                   @anaconda

python-libs.x86_64                     2.7.5-11.fc20                   @updates

python-lxml.x86_64                     3.2.4-1.fc20                    @anaconda

python-pillow.x86_64                   2.2.1-2.fc20                    @anaconda

python-pwquality.x86_64                1.2.3-1.fc20                    @anaconda

python-pycurl.x86_64                   7.19.0-17.20120408git9b8f4e38.fc20

python-six.noarch                      1.4.1-1.fc20                    @anaconda

python-slip.noarch                     0.6.0-1.fc20                    @anaconda

python-slip-dbus.noarch                0.6.0-1.fc20                    @anaconda

python-sssdconfig.noarch               1.11.2-1.fc20                   @anaconda

python-urlgrabber.noarch               3.9.1-32.fc20                   @anaconda

python3.x86_64                         3.3.2-8.fc20                    @anaconda

python3-beaker.noarch                  1.5.4-8.fc20                    @anaconda

python3-brlapi.x86_64                  0.6.0-9.fc20                    @anaconda

python3-cairo.x86_64                   1.10.0-6.fc20                   @anaconda

python3-gobject.x86_64                 3.10.2-1.fc20                   @anaconda

python3-libs.x86_64                    3.3.2-8.fc20                    @anaconda

python3-mako.noarch                    0.7.3-2.fc20                    @anaconda

python3-markupsafe.x86_64              0.18-1.fc20                     @anaconda

python3-pyatspi.noarch                 2.10.0-1.fc20                   @anaconda

python3-speechd.x86_64                 0.8-5.fc20                      @anaconda

rpm-python.x86_64                      4.11.1-7.fc20                   @anaconda

systemd-python.x86_64                  208-9.fc20                      @anaconda

[root@X nanocube-2.1]#

 

Loading...